LOW Ordner für IE Druck wird gelöscht!

Fragen/Anregungen zu neuen bzw. vorhandenen PlugIns

Moderatoren: Chris, Sven H

MrDigital

LOW Ordner für IE Druck wird gelöscht!

Beitrag von MrDigital » 07.05.2010, 17:23

Hallo
Ich habe die Ursache gefunden, warum ich im Internet Explorer mit Windows 7 nicht mehr drucken kann.
ClearProg löscht den Ordner C:\Users\<Benutzer>\AppData\Local\Temp\Low
Wie kann ich das verhindern? Habe schon etwas mit den PlugIns herumprobiert aber noch keinen Erfolg gehabt.

Benutzeravatar
Sven H
Administrator
Beiträge: 1983
Registriert: 13.08.2003, 00:00
Wohnort: Brandenburg
Kontaktdaten:

Beitrag von Sven H » 07.05.2010, 17:52

Hallo

Wie der Name schon fast verrät, handelt es sich da um den User-Temp-Ordner in dem sich der Low-Ordner befindet.

Grundsätzlich sollten im Temp aber keine systemnötigen Dateien liegen.

Wenn es gar nichts hilft, musst du die Option in CP "Windows-Temp-Verzeichnis" deaktivieren.


Gruß Sven

MrDigital

Beitrag von MrDigital » 07.05.2010, 18:46

Aber der LOW-Ordner liegt nun mal im Temp-Verzeichnis und wird für's Drucken oder die Druckvorschau des IE verwendet. Und das restliche im Temp möchte ich schon leeren, sonst brauche ich auch keine solche Software. Temp o h n e LOW löschen wäre die Lösung!

Benutzeravatar
Sven H
Administrator
Beiträge: 1983
Registriert: 13.08.2003, 00:00
Wohnort: Brandenburg
Kontaktdaten:

Beitrag von Sven H » 07.05.2010, 19:39

Hallo

Ich kann dein Problem nicht ganz nachvollziehen.
Im Temp-Ordner werden nur vorübergehend benötigte Dateien abgelegt.
Wenn ich diese Lösche, werden sie soweit benötigt neu angelegt.
Genau das passiert bei mir auch mit dem LOW-Ordner.

Wenn ich diesen lösche, wird er beim nächsten Start des IE neu angelegt.
Danach funktioniert auch die Druckvorschau noch.

Da scheint bei dir evtl. noch was anderes nicht korrekt zu sein.
Sind bei dir nach dem Beenden des IE irgendwelche Dateien in diesem Low-Ordner ?

Beendest du den IE bevor du mit CP löscht ?
Wenn ich den IE beim Löschen mit CP offen lassen und dann direkt
die Druckvorschau aufrufe, bleibt diese leer. Beende ich dann den IE
und starte ihn neu, dann klappt wieder alles.

Ist aber oberster Grundsatz, dass die Programme beim Löschen geschlossen sein sollten.


Gruß Sven

MrDigital

Beitrag von MrDigital » 07.05.2010, 22:46

Bei mir wird der LOW-Ordner leider definitiv und endgültig gelöscht. Auch ein Neustart usw. nützt nichts. Ich muss den Ordner manuell wieder erstellen und hinterher folgende Befehle eingeben:

1) C:\>icacls "%TEMP%"\Low
2) C:\>icacls "%TEMP%"\Low /setintegritylevel (OI)(CI)low

Erst dann funktioniert es wieder wie es sein sollte.

Nachzulesen übrigens hier:

http://www.winfuture-forum.de/lofiversi ... 31951.html

Scheinen doch noch mehr von dem Problem betroffen zu sein.

Benutzeravatar
Sven H
Administrator
Beiträge: 1983
Registriert: 13.08.2003, 00:00
Wohnort: Brandenburg
Kontaktdaten:

Beitrag von Sven H » 07.05.2010, 22:58

Wie gesagt, bei mir gibt es die Probleme nicht.

Folgendes Plugin sollte dir anstelle der Option "Windows Temp-Verzeichnis" weiterhelfen:

Code: Alles auswählen

&#91;User-Temp ohne LOW löschen&#93;
Info=Löscht den Windows-Temp-Ordner ohne low
File1=$UserTempDir$|*.*|SubFolder|$UserTempDir$\low

Gruß Sven

MrDigital

Beitrag von MrDigital » 08.05.2010, 07:52

Hallo Sven

Danke fürs Plugin aber leider funktionierts noch nicht wie gewünscht. Ich habe unter "Windows" links Windows Temp-Verzeichnis markiert und das löscht den LOW-Ordner gnadenlos. Wenn ich an dessen Stelle das LOW-Plugin aktiviere, wird dort gar nichts gelöscht. Oder muss ich etwa noch einen Pfad abändern/ergänzen?

Benutzeravatar
Sven H
Administrator
Beiträge: 1983
Registriert: 13.08.2003, 00:00
Wohnort: Brandenburg
Kontaktdaten:

Beitrag von Sven H » 08.05.2010, 10:36

Hallo

Bei mir gehts.
Hast du den Code in die ClearProgPlugins.ini eingefüht ?
Dann in der Pluginauswahl dieses Plugin aktiviert ?

Möglicherweise ist ja auch nichts zum Löschen da.
Kopier doch mal ein paar Dateien/Verzeichnisse in den Temp-Ordner
und lösche diesen dann mit CP über die neue Plugin-Variante.
Dann weiß man zumindest ob was zum Löschen da war.

Was zeigt denn die Vorschau an, wenn du nur dieses Plugin allein zum Löschen auswählst ?
Was zeigt die originale Variante zum Löschen des Windows-Temp in der Vorschau an ?


Gruß Sven

MrDigital

Beitrag von MrDigital » 08.05.2010, 22:43

Hallo Sven!
Sorry, jetzt funktioniert es doch. Ein paar TMP-Dateien bleiben erhalten, aber wenn ich testweise etwas reinkopiere, wird dies wieder gelöscht.
Vielen Dank und Gruss!

Benutzeravatar
Sven H
Administrator
Beiträge: 1983
Registriert: 13.08.2003, 00:00
Wohnort: Brandenburg
Kontaktdaten:

Beitrag von Sven H » 09.05.2010, 12:01

Ja, so sollte es sein.
Die Dateien, die da übrig bleiben sind gerade in Nutzung von irgendwelchen Programmen, so dass diese nicht gelöscht werden können.


Gruß Sven

Armin
Forum-Gott
Beiträge: 709
Registriert: 19.02.2004, 00:00

Beitrag von Armin » 25.08.2010, 21:39

Hallo Sven

Bitte entschuldige, dass ich diesen Thread-Veteran wieder aufwärme.

Dein Plugin für Usertemp ohne den low Ordner zu löschen funktioniert auf Windows 7 Pro bestens, vielen Dank.

Wäre es wohl möglich, diese Funktionalität in das Hauptprogramm für
Windows --> Windows Temp-Verzeichnis zu übernehmen?

Es gibt mehr und mehr Windows 7 / Windows 2008 Installationen, die alle von diesem Effekt betroffen sind.

Vielen Dank und Gruss
Armin

Benutzeravatar
Sven H
Administrator
Beiträge: 1983
Registriert: 13.08.2003, 00:00
Wohnort: Brandenburg
Kontaktdaten:

Beitrag von Sven H » 26.09.2010, 12:45

Hallo

Da das Problem nicht auf allen Rechner auftritt (z.B. auf meinem nicht), habe
ich jetzt eine zusätzliche Option bei "Extras" eingefügt, über die man das Löschen
des Low-Ordners im Temp verhindern kann.

Wer eine Vorabversion testen möchte, schickt mir einfach ne Mail.


Gruß Sven

Antworten